Skip to main content
← All vulnerabilities
CVE-2022-29203GHSA-JJM6-4VF7-CJH4BIT-TENSORFLOW-2022-29203PYSEC-2026-1012PYSEC-2026-3207PYSEC-2026-3344

Integer overflow in `SpaceToBatchND` in TensorFlow

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.6.4, 2.7.2, 2.8.1, 2.9.0
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: poc
  • Automatable: no
  • Technical impact: partial

Summary

TensorFlow is an open source platform for machine learning. Prior to versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4, the implementation of `tf.raw_ops.SpaceToBatchND` (in all backends such as XLA and handwritten kernels) is vulnerable to an integer overflow: The result of this integer overflow is used to allocate the output tensor, hence we get a denial of service via a `CHECK`-failure (assertion failure), as in TFSA-2021-198. Versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4 contain a patch for this issue.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: poc · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • tensorflow tensorflow

    fixed in 2.6.4; From 2.7.0rc0 · fixed in 2.7.2; From 2.8.0rc0 · fixed in 2.8.1; From 2.9.0rc0 · fixed in 2.9.0

  • tensorflowPyPI

    fixed in 2.6.4

  • tensorflowPyPI

    From 2.7.0 · fixed in 2.7.2

  • tensorflowPyPI

    From 2.8.0 · fixed in 2.8.1

  • tensorflow-cpuPyPI

    fixed in 2.6.4

  • tensorflow-cpuPyPI

    From 2.7.0 · fixed in 2.7.2

  • tensorflow-cpuPyPI

    From 2.8.0 · fixed in 2.8.1

  • tensorflow-gpuPyPI

    fixed in 2.6.4

  • tensorflow-gpuPyPI

    From 2.7.0 · fixed in 2.7.2

  • tensorflow-gpuPyPI

    From 2.8.0 · fixed in 2.8.1

  • tensorflow-gpuPyPI

    fixed in 2.6.4; From 2.7.0 · fixed in 2.7.2; From 2.8.0 · fixed in 2.8.1

  • tensorflow-cpuPyPI

    fixed in 2.6.4; From 2.7.0 · fixed in 2.7.2; From 2.8.0 · fixed in 2.8.1

  • tensorflowPyPI

    fixed in 2.6.4; From 2.7.0 · fixed in 2.7.2; From 2.8.0 · fixed in 2.8.1

References 7

GitHub · tensorflow/tensorflow