Skip to main content
← All vulnerabilities
CVE-2022-29195GHSA-H48F-Q7RW-HVR7BIT-TENSORFLOW-2022-29195PYSEC-2026-1003PYSEC-2026-3196PYSEC-2026-3335

Missing validation causes denial of service in TensorFlow via `StagePeek`

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.6.4, 2.7.2, 2.8.1, 2.9.0
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: poc
  • Automatable: no
  • Technical impact: partial

Summary

TensorFlow is an open source platform for machine learning. Prior to versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4, the implementation of `tf.raw_ops.StagePeek` does not fully validate the input arguments. This results in a `CHECK`-failure which can be used to trigger a denial of service attack. The code assumes `index` is a scalar but there is no validation for this before accessing its value. Versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4 contain a patch for this issue.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: poc · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • tensorflow tensorflow

    fixed in 2.6.4; From 2.7.0rc0 · fixed in 2.7.2; From 2.8.0rc0 · fixed in 2.8.1; From 2.9.0rc0 · fixed in 2.9.0

  • tensorflowPyPI

    fixed in 2.6.4

  • tensorflowPyPI

    From 2.7.0 · fixed in 2.7.2

  • tensorflowPyPI

    From 2.8.0 · fixed in 2.8.1

  • tensorflow-cpuPyPI

    fixed in 2.6.4

  • tensorflow-cpuPyPI

    From 2.7.0 · fixed in 2.7.2

  • tensorflow-cpuPyPI

    From 2.8.0 · fixed in 2.8.1

  • tensorflow-gpuPyPI

    fixed in 2.6.4

  • tensorflow-gpuPyPI

    From 2.7.0 · fixed in 2.7.2

  • tensorflow-gpuPyPI

    From 2.8.0 · fixed in 2.8.1

  • tensorflow-cpuPyPI

    fixed in 2.6.4; From 2.7.0 · fixed in 2.7.2; From 2.8.0 · fixed in 2.8.1

  • tensorflow-gpuPyPI

    fixed in 2.6.4; From 2.7.0 · fixed in 2.7.2; From 2.8.0 · fixed in 2.8.1

  • tensorflowPyPI

    fixed in 2.6.4; From 2.7.0 · fixed in 2.7.2; From 2.8.0 · fixed in 2.8.1

References 7

GitHub · tensorflow/tensorflow