Skip to main content
← All vulnerabilities
CVE-2022-29187

Bypass of safe.directory protections in Git

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.30.5, 2.31.4, 2.32.3, 2.33.4, 2.34.4, and 3 more
None on Exploit-DB, Metasploit or GitHub

Summary

Git is a distributed revision control system. Git prior to versions 2.37.1, 2.36.2, 2.35.4, 2.34.4, 2.33.4, 2.32.3, 2.31.4, and 2.30.5, is vulnerable to privilege escalation in all platforms. An unsuspecting user could still be affected by the issue reported in CVE-2022-24765, for example when navigating as root into a shared tmp directory that is owned by them, but where an attacker could create a git repository. Versions 2.37.1, 2.36.2, 2.35.4, 2.34.4, 2.33.4, 2.32.3, 2.31.4, and 2.30.5 contain a patch for this issue. The simplest way to avoid being affected by the exploit described in the example is to avoid running git as root (or an Administrator in Windows), and if needed to reduce its use to a minimum. While a generic workaround is not possible, a system could be hardened from the exploit described in the example by removing any such repository if it exists already and creating one as root to block any future attacks.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • git git

    From 2.30.3 · fixed in 2.30.5; From 2.31.2 · fixed in 2.31.4; From 2.32.1 · fixed in 2.32.3; From 2.33.2 · fixed in 2.33.4; From 2.34.2 · fixed in 2.34.4; From 2.35.2 · fixed in 2.35.4; From 2.36 · fixed in 2.36.2; From 2.37 · fixed in 2.37.1

References 15

GitHub · git/git

github.blog

lore.kernel.org

openwall.com

lists.fedoraproject.org

support.apple.com

seclists.org

lists.debian.org

security.gentoo.org