Skip to main content
← All vulnerabilities
CVE-2022-29041GHSA-M3P3-2GP6-GHQ8

Jenkins Jira Plugin 3.7 and earlier, except 3.6.1, does not escape the name and description of Jira Issue and Jira Release Version parameter

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.7.1, 3.6.1
None on Exploit-DB, Metasploit or GitHub

Summary

Jenkins Jira Plugin 3.7 and earlier, except 3.6.1, does not escape the name and description of Jira Issue and Jira Release Version parameters on views displaying parameters, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • Jenkins project Jenkins Jira Plugin

    through 3.7

  • org.jenkins-ci.plugins:jiraMaven

    From 3.7.0 · fixed in 3.7.1

  • org.jenkins-ci.plugins:jiraMaven

    fixed in 3.6.1

References 1

jenkins.io