Skip to main content
← All vulnerabilities
CVE-2022-2884

A vulnerability in GitLab CE/EE affecting all versions from 11.3.4 prior to 15.1.5, 15.2 to 15.2.3, 15.3 to 15.3 to 15.3.1 allows an an auth

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 15.1.5, 15.2.3, 15.3.1
1 on Exploit-DB, 1 proof of concept on GitHub
  • Exploitation: poc
  • Automatable: yes
  • Technical impact: total

Summary

A vulnerability in GitLab CE/EE affecting all versions from 11.3.4 prior to 15.1.5, 15.2 to 15.2.3, 15.3 to 15.3 to 15.3.1 allows an an authenticated user to achieve remote code execution via the Import from GitHub API endpoint

Timeline

  1. CVE published
  2. Public exploit on Exploit-DB

    EDB-51181

  3. CISA SSVC assessment

    Exploitation: poc · Automatable: yes · Technical impact: total

  4. Record last updated
  5. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • GitLab GitLab

    From 11.3.4 · fixed in 15.1.5; From 15.2 · fixed in 15.2.3; From 15.3 · fixed in 15.3.1

References 6

gitlab.com

hackerone.com

packetstormsecurity.com

Exploit-DB

GitHub · m3ssap0/gitlab_rce_cve-2022-2884