Skip to main content
← All vulnerabilities
CVE-2022-25858GHSA-4WF5-VPHF-C2XC

Regular Expression Denial of Service (ReDoS)

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 4.8.1, 5.14.2
None on Exploit-DB, Metasploit or GitHub

Summary

The package terser before 4.8.1, from 5.0.0 and before 5.14.2 are vulnerable to Regular Expression Denial of Service (ReDoS) due to insecure usage of regular expressions.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a terser

    fixed in 4.8.1; From 5.0.0; fixed in 5.14.2

  • tersernpm

    fixed in 4.8.1

  • tersernpm

    From 5.0.0 · fixed in 5.14.2

References 5

snyk.io

GitHub · terser/terser