Skip to main content
← All vulnerabilities
CVE-2022-2500

A cross-site scripting issue has been discovered in GitLab CE/EE affecting all versions before 15.0.5, 15.1 prior to 15.1.4, and 15.2 prior

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 15.0.5, 15.1.4, 15.2.1
None on Exploit-DB, Metasploit or GitHub

Summary

A cross-site scripting issue has been discovered in GitLab CE/EE affecting all versions before 15.0.5, 15.1 prior to 15.1.4, and 15.2 prior to 15.2.1. A stored XSS flaw in job error messages allows attackers to perform arbitrary actions on behalf of victims at client side.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • GitLab GitLab

    From 0.0 · fixed in 15.0.5; From 15.1 · fixed in 15.1.4; From 15.2 · fixed in 15.2.1

References 3

gitlab.com

hackerone.com